您的位置:首页>>安全防范
多个Linux内核远程拒绝服务漏洞 威胁预警

 [ 发布时间:20/09/28    来源:    查看次数:1660 ]

近日,Red Hat官方发布了一份安全公告,公告中指出了Linux内核中存在的多个基于TCP的远程拒绝服务漏洞。其中包括一个名为“SACK Panic”的高危漏洞和其他两个中危漏洞。  

漏洞概述

CVE-2019-11477 SACK Panic

CVE-2019-11477称为“SACK Panic”,是一个整型溢出漏洞,可由远程攻击者向易受攻击的系统发送一系列TCP选择性确认(SACK)包触发,这可能导致系统崩溃。成功利用此漏洞将导致受影响系统上的拒绝服务(DoS)。

 受影响版本:

Linux 内核版本 >= 2.6.29

已修复漏洞的稳定内核版本:

Linux 内核版本4.4.182、4.9.182、4.14.127、4.19.52、5.1.11

 解决方案:

可使用链接中检测脚本确定您的系统当前是否容易受到此漏洞的攻击:

  https://access.redhat.com/security/vulnerabilities/tcpsack

应用补丁程序:

PATCH_net_1_4.patch解决了Linux内核版本大于或等于2.6.29中的漏洞:

  https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_1_4.patch

此外,Linux内核版本>= 4.14需要第二个补丁PATCH_net_1a.patch:

  https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_1a.patch

或禁用SACK(/proc/sys/net/ipv4/tcp_sack设置为0)

更多缓解措施详见:

  https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md

CVE-2019-11478 SACK Slowness 或过量资源消耗

CVE-2019-11478是一个过量的资源消耗漏洞,可以由远程攻击者向易受攻击的系统发送一系列TCP选择性确认(SACK)包触发,从而导致TCP重传队列的碎片化。此外,在4.15之前的Linux内核上,攻击者可能能够进一步利用分段队列,为后续针对同一TCP连接接收的SACK导致昂贵的链表遍历,造成进一步碎片化,由此被称为“SACK Slowness”。成功利用此漏洞将严重阻碍系统性能,并可能导致DoS。

 受影响版本:

SACK Slowness 影响版本小于 4.15 的Linux 内核

过量资源消耗影响全版本Linux 内核

 已修复漏洞的稳定内核版本:

Linux 内核版本4.4.182、4.9.182、4.14.127、4.19.52、5.1.11

 解决方案:

应用补丁程序 PATCH_net_2_4.patch:

 https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_2_4.patch

或禁用SACK(/proc/sys/net/ipv4/tcp_sack设置为0)

更多缓解措施详见:

 https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md

CVE-2019-11479

CVE-2019-11479是一个超额资源消耗漏洞,可以在远程攻击者为TCP连接设置较低的最大段大小(MSS)时触发,从而导致易受攻击的系统利用额外的带宽和资源。利用此漏洞将导致受影响的系统以最大的资源消耗运行,影响系统性能。

 受影响版本:

影响全版本Linux 内核

 已修复漏洞的稳定内核版本:

Linux 内核版本4.4.182、4.9.182、4.14.127、4.19.52、5.1.11

 解决方案:

应用补丁程序PATCH_net_3_4.patch:

 https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_3_4.patch

应用补丁程序PATCH_net_4_4.patch:

 https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_4_4.patch

更多缓解措施详见:

 https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md


  版权所有:海南外国语职业学院 网络信息中心                          
Copyright (C) 2015 Hainan College Of Foreign Studies